FortiSOAR Knowledge Base
FortiSOAR: Security Orchestration and Response software provides innovative case management, automation, and orchestration. It pulls together all of an organization's tools, helps unify operations, and reduce alert fatigue, context switching, and the mean time to respond to incidents.
Andy_G
Staff
Staff
Article Id 193225
Description

Issue:

SoftTimeLimitExceeded() error, as shown in the following image, occurs in playbooks while fetching records from CyOPs™.



Root Cause:

This issue occurs when the playbook is fetching a large number of records from CyOPs™, which takes more than 3600 milliseconds (the standard soft playbook time limit) to be fetched.




Solution

Fix:


In the above case we advised user to limit the selection of the number of input records in smaller batches. 


Applicable Version:

Any CyOPs™ version


Contributors